Erro ao gerar builds no Ionic2 com o plugin do OneSignal

Um erro comum que pode acontecer quando você for utilizar o Ionic2 com o plugin do OneSignal é a PromiseError. O log do console do Ionic diz que está faltando um arquivo do OneSignal mas na verdade é uma incompatibilidade que pode ser resolvida com os POD Update.

Sendo assim vamos para os primeiros passos para fazer o fix deste problema:

sudo gem install cocoapods
pod repo update

Depois execute

cordova plugin rm onesignal-cordova-plugin --save
cordova plugin add onesignal-cordova-plugin --save

Lembre-se de executar os comandos acima dentro da pasta do seu projecto do Ionic